WD MyPassport Ultra 1TB-not wireless - USB connection
Results 1 to 6 of 6

Thread: WD MyPassport Ultra 1TB-not wireless - USB connection

  1. #1
    Junior Member
    Join Date
    Apr 2014
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts

    WD MyPassport Ultra 1TB-not wireless - USB connection

    On 8 November 2016 I ordered and later received this piece of hardware.
    It was purchased as an Xmas present so it was left unopened and then wrapped.
    I was later informed that the recipient could not use this item as it effected their wireless mouse, to such an extent that it could not be used.

    The item was returned to me and after a slight problem getting my computer to at least recognise the hardware, I too found that I was unable to use my mouse.
    I have to identical 'mice' which are the same as that owned by the recipient.

    I use one mouse for my desktop and one for my laptop. Neither mouse would work with the HDD plugged in. I have tried both items in all the USB connections on the desktop but the HDD kills the mouse.

    Before I return the HDD for a refund, which I would now declare as NOT FIT FOR PURPOSE, I was wondering if there is a solution to this problem - though I doubt it having spent many hours of research via the net - as the problem seems to be an inbuilt one. The main reason for getting this HDD was that it is portable - but not much use if it is meant to be used anywhere and in particular with a laptop.

    Rgds
    Damascus

  2. #2
    Super Moderator Mick@Scan's Avatar
    Join Date
    Jul 2012
    Posts
    368
    Thanks
    14
    Thanked 3 Times in 3 Posts
    Damascus,

    I am sorry to hear about the problems you are having, are you able to test the drive in a desktop PC rather than a laptop to see you have the same issue?

    Regards,

  3. #3
    Junior Member
    Join Date
    Apr 2014
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Mick
    Thanks for your involvement.
    Yes, I have tested the HDD in both the desktop and the laptop and have even switched the mice[which are identical Microsoft wireless mobile mouse 4000 to double check.
    In both cases the mouse is out of control. I would have thought you may have had some feedback on this problem? It is not that uncommon.
    I have 2 USB connections on the front and 6 on rear panel - I have swapped both round to see if their positioning made a difference - it did not.
    Advice from various forums has been - get a wired mouse - wrap the HDD in foil - wrap the HDD USB connection in foil - wrap the mouse dongle in foil[daftest idea] - get a longer lead for the
    HDD.
    For now I have a pretty looking small glossy black box which is useless.

    Rgds
    Damascus

  4. #4
    Junior Member
    Join Date
    Apr 2014
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Mick
    Could I please have an update?
    Rgds
    Damascus

  5. #5
    Super Moderator Mick@Scan's Avatar
    Join Date
    Jul 2012
    Posts
    368
    Thanks
    14
    Thanked 3 Times in 3 Posts
    Damascus,

    I am very sorry for the delay, please ensure you you log a query via the Scan website:

    https://www.scan.co.uk/help/orders/r...urning-an-item

    Regards,

  6. #6
    Junior Member
    Join Date
    Apr 2014
    Posts
    8
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by [email protected] View Post
    Damascus,

    I am very sorry for the delay, please ensure you you log a query via the Scan website:

    https://www.scan.co.uk/help/orders/r...urning-an-item

    Regards,
    I should think so - two months to reply and then with no help or suggestions - I thought Scan were proud of their customer service.
    I have sent a request via the link you gave.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •